请选择 进入手机版 | 继续访问电脑版
 找回密码
 快速注册

QQ登录

只需一步,快速开始

文本处理 实现火山PC和易语言取MD5数据一致

0
回复
126
查看
[ 复制链接 ]

209

主题

225

帖子

1366

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1366
2021-3-28 12:25:46 显示全部楼层 阅读模式

众所周知火山pc使用的是Unicode  又或者可以说是 utf-16编码。  易语言用的是多字节编码也可以说是ansi编码。

两个编码不同,最终会导致取md5出现错误。下面介绍一下如何让两个md5数据统一。








易语言代码:


.版本 2
.支持库 dp1

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

编辑框2.内容 = 取数据摘要 (到字节集 (编辑框1.内容))




火山PC中的代码:

1、首先配置模块。

20210328121345.png


2、
调用:编辑框2.内容 = 加解密类.取数据MD5 (文本到多字节 (编辑框1.内容, 假))

搜狗截图20210328122452.png


最后运行结果:

md5.png








上一篇:火山PC实现文件枚举目录枚举-文件查找类
下一篇:火山视窗如何使用静态编译?
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 快速注册

本版积分规则